録画人間の末路 -

人は記録をしながらじゃないと生きていけない

Windows7でSP1を入れるとMPEG2-TSの再生の際に不具合が出ます。

2011-02-24 22:31:34 | 意味なしレビュー
今日のコメントでもらった情報なのですが、Windows7のSP1をインストールすると、WindowsMediaPlayerで一部のTSファイルが音が出なくなる、あるいは音しか出なくなるという問題が出ているそうです。
ウチにはWindows7なPCが2台あるので、試しに一台に入れてみましたSP1。再起動してWMPを立ち上げると、設定が一からやり直しになります。うーん。
で、適当なTSファイルを再生させると・・・。CS系は一通り問題なし、地上デジタルも手元にあるものの範囲なら問題なし(あまりないけど)。
最後は、BSデジタルのTSファイルですが・・・。見事、音が出ません(涙)。BS-TBS/BSフジ/BS11/TwellVの番組丸ごとのTSファイルを再生してみましたが、全部音が出ません。途中で音声の具合が変わるとかが原因かとにらみ、一部分だけをMudocCutterで切り出してみましたが、やっぱりダメです。その一方で、BS朝日/BSジャパン/BS日テレ/NHK BS1/NHK BS2/NHK/BS-Hiに関しては音が出ます。この差はいったいなんでしょう? 謎ですが、スッキリしたい人はSP1にしないか、あるいは別のソフトで再生するのが良さそうです。

追記:なお、一部でCinaviaの仕業では・ といわれていますが、それはないでしょう。
ウチでは、映画版の、30秒でシナビてしまう映像(映画"ザ・タウン"の紹介番組の該当部分)だけを切り出して、WMP12の連続再生で1時間以上再生させっぱなしにしておきましたが、映像が止まることも音が消えることもありませんでした。そっち絡みなら一番わかりやすいCinaviaに対応させないわけはありませんから、おそらくWMP12のバグと思われます。条件を調べるより、MSの修正を待ったほうが早いかも知れません。
『コンピューター機器』 ジャンルのランキング
コメント (28)   トラックバック (2)   この記事についてブログを書く
この記事をはてなブックマークに追加
« trpファイルの視聴とエンコード | トップ | 閉鎖的商売方法は電子書籍に向い... »

28 コメント

コメント日が  古い順  |   新しい順
Unknown (Unknown)
2011-02-24 23:36:34
某掲示板曰く東芝マスターの局が音がでなくなるそうです。
Unknown (FRS)
2011-02-24 23:46:50
うちはマザーのリコールによる入換えが控えているので、その時にクリーンインストールしようかとまだSP1入れていないんですが、曲者みたいですねぇ
何事も無く更新できた人からブルーバックでどうにもならない人まで、さらにはアップデートできない問題があるとかでマイクロソフトが調査を開始したとか

TSファイルの件ではCinaviaなんじゃないかとの噂も出ているようですが真実は如何に・・・
Unknown (krmmk3)
2011-02-25 00:04:00
>2011-02-24 23:36:34さん
本当ですか? それだとこっちでは判別のしようがないですね。

>FRSさん
わたしも同じです。だから実験用も兼ねちゃっているんで。
30秒でシナビるCinavia映像を20分間リピート再生しましたが、無事でした。Cinaviaの影響ではないです。
Unknown (Unknown)
2011-02-25 00:19:22
始めまして。
わたしも昨日SP1をインストールしたら、局によってTSの音声再生できなくなって困ったので、
さきほど SP1 アンインストールしてしまいした。
アンインストール後は普通に再生できるように戻りました。
Unknown (Unknown)
2011-02-25 00:29:17
2011-02-25 00:19:22 です。
うちにあったいくつかの地デジファイルでは、

テレ朝/テレ東/TBS/TOKYO MX は OK
NHK/NHK教育/フジ/TVK は NG

でした。WOWOW も OK。
SP1はやっぱ慎重に? (通りすがり)
2011-02-25 00:40:07
ここしばらく無かったけど、MSのSP1は、非常に危険ですね。
昔、酷い目に有った事もあるので、SPの適用はついつい慎重になりすぎるくらいです。(^^;
(NT4.0とか95とかとかとか...。)
ただのセキュリティロールアップパッケージと変わらないと聞いてたので週末にでもと思ってたけど、延期しよう。
SP1aが出るのを待つべきか?
Unknown ()
2011-02-25 00:57:17
SP1入れる前はNHK総合「江」は再生できない。エラになります。

SP1はどうかは次回録画時にでも確認してみましょう。

容量節約のためとっととtsファイルは
DVD規格mpgに変換しちゃうので・・
Unknown (2011-02-24 23:36:34)
2011-02-25 01:06:46
うちには7が無いので検証できないのですがこちらのスレ
高画質なアニメを望むスレ44
ttp://kamome.2ch.net/test/read.cgi/asaloon/1297414260/
に一部BS各局のマスターがのっております。
------
● NECマスター使用局
NTV, EX, TBS, TX, MBS, ABC, TVO, THK, CBC / MX, TVS, CTC, GBS, BS-TBS

● 東芝マスター使用局
CX, KTV, ytv, CTV, NBN, TVA / tvk, MTV, SUN, KBS, BS11, BS-J, BS-Fuji
------

BS-TBSはNECらしいので一概に東芝マスターが、とはいえないかもです。
コーデックを入れると一応音はでるようになるみたいです。

マスターについて語るスレ5
ttp://toki.2ch.net/test/read.cgi/tvsaloon/1268229288/
こちらには地上波各局のマスターがのっています。
局別みたいですね (KJ)
2011-02-25 01:13:02
遭遇しました。 ちょうどこちらにお邪魔するタイミングで(笑)。
元々安定したOSでしたし、ウイルス対策を(ウチでは)MSEにしていたこともあるのか、セブン導入以来ほぼトラブルフリーだったのですが・・・おまけに SP1 がバグフィックス程度だと聞けば警戒感なくインストールしてしまうのも仕方ないでしょう。。。
と自己弁護してみたり(笑)。 慣れって怖い。

ウチでもWMPの再生可否を 「軽く」 チェックしてみました。
やっぱり局別のような印象ですね。(環境:AMD870+GTX460)
正常: ntv ex tbs tx mx bs2 bshi bsn bsj wowow
無音: nhkg nhke cx tvk bst bsf bs11 bs12
両方: bs1

WMP自体も、再生を始めるときのレスポンスが悪くなったような気がします。 ひと呼吸というか、パカパカというか、1度何かを読み込んでから再生を始めるような。
「何でも再生できるWMP」 が Windows7 のウリでもあったわけですし、早く何とかしてほしいですね。とりあえずシステム復元で戻るかなぁ?
Unknown (krmmk3)
2011-02-25 01:27:44
いやー、みなさんの関心強いですね。わたしらにとっては大問題ですからね。

>2011-02-25 00:19:22さん
音が出なかったファイルをSP1を入れていないもう一台のWindows7PCに入れたところ、わたしの環境でも再生出来ました。厳密に言うとWMPの不具合なんでしょうが、しばらく入れない方がいいですね。

>2011-02-25 00:29:17さん
地上波でもいろいろあるんですね。いったいなんの相性なんでしょうかね。

>通りすがりさん
XPやVistaではむしろSP1は良かったというイメージがあるんですが、今回はやっちゃったなぁと。
WMPだけ新しくアップするんじゃないですかね。

>谷さん
江はSP1以前ではダメですか。地上波とBSもあるんでしょうけど、なんででしょうね。江はPCで撮ってないんで、今度試してみましょうか。

>2011-02-24 23:36:34さん
なんと細かい情報(^^;)
BS-TBSはNECですか古いのも先週録画したやつもダメでしたので、東芝だからダメとは言い切れないですね。

>KJさん
BS1が両方ある、というのは興味深い話ですね。でも、わたしらから見ると違いわからないですよね。
ほかの再生ソフト入れる必要すら感じなかった7のWMPなのに、しょせんはWMPかという感じもします。まぁ元に戻ればいいだけでしょうね。
Unknown (emanon)
2011-02-25 19:02:01
>XPやVistaではむしろSP1は良かったというイメージがあるんですが

XPのSP1は今回の問題とはと違いHDD破壊で有名になりませんでしたっけ? 
お店のサービスカウンターにメーカー製PCの山ができたと 当時はメモリー少なかったからなのでしょうけどね
Unknown (FRS)
2011-02-25 19:19:59
某所で内部の者と名乗る人が著作権への配慮うんぬんと発言してますが
まぁそれ自体の真偽は放っておいて、ファイルの信号情報でも読み取って再生するかどうか判断しているんですかね?
Unknown (Unknown)
2011-02-25 20:14:09
著作権絡みなら、保護されてないTSはすべてダメになるはず。
局や番組で違うとの事ですが、同じ番組を二部にわけて録画したけど、片方だけ音なしになったのがありました。
gopどうのこうのとの書き込みもありましたねえ

wmp12のメディア再生に魅力を感じ7にした人もいるはずなんですが、、、
Unknown (krmmk3)
2011-02-25 21:09:19
>emanonさん
そうでしたっけ? わたしはそのEX-VISION1700TVを使っていたのですが、あれはWindowsXPだとSP2にしないとインストールできない仕様になっているんです。なのにみんなSP1止まりにして「インストールできない」って声があちこちからあたものですから、てっきりみんなSP1がよくてSP2はダメと思っている印象があったのですが。

>FRSさん
その発言は明らかにウソです。Cinaviaに対応してないですから、この音でない問題。たぶん特定のAACを読めない不具合ですよ。

>2011-02-25 20:14:09さん
片方OKになったものもありますか。ウチはBS-TBSの番組で試してますが、どうやっても音でないんですよ。
WMP12は結構よかったので再生ソフトをほかに入れてなかったんですよ。とても残念ですが、近いうちに直してくれるとは思っています。
Win7x64 Ultimate SP1で現象を確認 (makita)
2011-02-25 21:51:54
私の環境でもさきほどワンセグ放送のTSファイルをWMP12で再生させたところ音声が一切出ないという現象を確認いたしました。

音声が出ないのは下記のワンセグ放送です。(ワンセグは全部アウトかな?)
関西テレビ、NHK総合大阪、MBS毎日放送

もともとTSファイルはTVH264もしくはTVTest+BonDriver_Fileの組み合わせで再生しているので影響は小さいのですけども。
Unknown (siinamon)
2011-02-25 23:01:28
同様に音が出ないことを確認。
ただ自分はこのままSP1導入。
理由はSP1インスコするのに数時間かかったので;;
出張時、動画閲覧用として買ったのですが、モバイルPCの遅いこと。
CPUはAthlon2Neo K325ですが、Phenom2X6 1090Tのデスクトップと比べたら超遅せー。
それはともかく動画マシンとして買ったので、WMPがまともに動かないから困るかというと、PDVD1O入れてるので困らないからまあいいかという消極的理由でSP1は継続。
追加情報でいえば音が出ないTSもRD-X8、X9でH264化したものであれば問題なく再生できました。
まあ当たり前なのかもしれませんが。
Unknown (FRS)
2011-02-26 00:06:17
書き方が悪かったですかね、Cinaviaとは無関係にTSファイルの特定の部分を読み込んで、意図的に再生を行っていないのでは?ってことなのですが・・・

まぁ確かにWMPはファイル確認程度にしか使わないので、騒ぐほどの問題じゃないかもしれませんね。
Unknown (krmmk3)
2011-02-26 00:59:54
>makitaさん
あ、本当だ。同じ番組を同時に録画したファイルでも、ワンセグだと音でないですね。たぶんワンセグはアウトでしょう。

>siinamonさん
高速なデスクトップならともかく、モバイル機だとやっぱり時間かかりますし、簡単に戻したくないですね。RDは音声もエンコードしましたっけ? 

>FRSさん
いえ、理解はしているつもりですが、Cinaviaという一番わかりやすい手段を使わずに、ほかの方法で動画の解析を、それもWMPが立ち上がる数秒でするとは思えないという意味です。
わたしはWindows7自体実験&録画&エンコ&確認用にしか使っていないのでWMPしか入れてなかったんですよ。それがちょっと痛いです。
Unknown (tichi73)
2011-02-26 01:02:16
昨日の、2011-02-25 00:29:17/2011-02-25 00:19:22 です。

音声が再生できない TS から、AAC だけ分離させてみたところ、
WMP12 で音声ファイルとして普通に再生できました。

なので、WMP12 に当該 AAC チャンネルの再生能力が無いのではなく、
TS としての再生時に何らか制約をかけて、
再生していないだけ、と考えることはできるかもしれません。
Unknown (ATX5000Max)
2011-02-26 14:27:29
TS再生では問題出るのか。再生でなくトラコン用ソースファイルとしては大丈夫な感じだが、、、まぁしばらくSP1当てない方がいいか。
Unknown (emanon)
2011-02-26 22:09:11
 >てっきりみんなSP1がよくてSP2はダメと思っている印象があったのですが。

当時のメーカー製PCは最初からスワップすることがあたりまえ前提のメモリー量で出荷しても普通でしたから SP1でHDDスワップ破壊したので一時期恐ろしくてSP1で止めておくのが無難だったのですよ その内1年たったらただの箱と言うくらい性能倍々で伸びましたし

円高でメモリー増設が流行して問題ないと判るるまでSP1か、TS抜きするにはSP1だったからか

 あれはチューナーからリアルタイムで取込むでOKだったのかな? 今となったら過去の話ですが知ってる人いますか
Unknown (krmmk3)
2011-02-27 21:00:30
>tichi73さん
報告、どうもです。
AACだけなら大丈夫だとすると、TSファイルの情報のせいですかね。わたしらのわからない情報を一部のチャンネルでは埋め込んである、と考えることはできそうですね。未だにWMPの修正ファイルでませんし。

>ATX5000Maxさん
HNが長くなりましたね(^^;)
SP1当ててもWMP12とメディアセンター以外のソフト使えば大丈夫ですよ。

>emanonさん
そうでしたか。細かい弱点が技術の進歩で問題なくなったから、枯れているSP1をつかっていたとかですかね。
わたしはSP2が当たり前になってから以降しかTSを扱ったことないので、そこら辺の事情は不明です。
Unknown (Unknown)
2011-02-28 14:38:37
自分で撮影した動画を、MPEG2+AACでTSエンコすると音が出ない、MPEG2+AC3でTSエンコすると問題なし。単なるバグなんでしょう。
Unknown (krmmk3)
2011-02-28 22:54:37
>2011-02-28 14:38:37さん
自分で作った動画もダメとなりますと、WMP12の不具合は確実ですが、もう条件は特定不明ですね。WMP12だけでも戻せるようにして欲しいものです。
Unknown (Unknown)
2011-03-22 18:16:08
某所でとりあえずの対処方法が出てました。
今回の不具合の原因になっているのはmfds.dllで
無印の物と入れ替える事で音声が出るようになるようです。

試す方は自己責任でお願いします。
Unknown (krmmk3)
2011-03-22 21:49:40
>2011-03-22 18:16:08さん
情報ありがとうございます。ただ、ウチの場合Windows7にSP1を入れているのが32ビット版で、入れてないのが64ビット版なんで、ちょっと上書きには使えそうにないので試すのは無理ですね。
TSの音声再生 (ウィーク)
2011-09-21 18:39:50
http://freesoft.tvbok.com/windows7/operation/sp1_ts.htmlをみると音声がでるようです。おためしあれ!
Unknown (krmmk3)
2011-09-21 23:09:27
>ウィークさん
その話は前から出てますね。わたしとしては、これを不具合と認めてMicroSoftから修正パッチが出てほしかったのですが。そろそろあきらめ時ですかねぇ。

コメントを投稿


コメント利用規約に同意の上コメント投稿を行ってください。

数字4桁を入力し、投稿ボタンを押してください。

あわせて読む

2 トラックバック

この記事のトラックバック  Ping-URL
ブログ作成者から承認されるまでトラックバックは反映されません。
Windows 7 SP1でのtsファイルの扱い (ASARI.JP : Diary)
Windows 7 SP1をインストールするとMPEG-2 TSファイルの再生に不具合が出る場合があるようです。具体的には録画人間の末路さんのブログ記事に詳しいですが、どうやらWindows Media Playerで再生した場合になるみたいですね。 私はWMPは一切使っていないので確認できていま...
Windows 7 SP1をインストールするとMPEG2-TSファイルが再生できなくなる (覚え書き | OSS Fan)
先日Windows 7のService Pack 1がリリースされた。 特に疑いもせずにWindows Updateでインストールしたが、その後、PT1で録画したMPEG2-TSファイルがWindows Media Playerで正常に再生できなくなっていることに気づいた。 症状としては、大きく2通りで、 (1) 映像は表示さ...