小部屋の覚え書きRO

ど根性軟弱ネットゲーマーさーくすのブログ。本家の小部屋から日記をこちらにしました。
本家は主に電子工作ネタで更新中

広告

※このエリアは、60日間投稿が無い場合に表示されます。記事を投稿すると、表示されなくなります。

[ucom]HSRP

2016-09-18 21:55:58 | 組み込み・マイコン

Project-M No.16 HSRP

HSRP実験。HSRPとはHot Standby Router Protocolの略。
端末からみたゲートウェイL3SWを冗長化する。
L3SW2台の間で仮想IPアドレスを持ち、
片方がダウンしても通信がすぐに復旧する。
実験の構成は次の通り。

各ループバックとVLAN、3750と1812J間はOSPF指定する。
3750と2960GのトランクはVLAN100のスパニングツリーを指定する。
3750にVLAN100にはHSRPのconfigである
standby ipを指定する。
投入configは以下の通り。

●3750-1
vlan 100
!
spanning-tree vlan 100
!
spanning-tree mode rapid-pvst
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet1/0/1
 no switchport
 ip address 10.0.1.1 255.255.255.252
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100
 switchport mode trunk
!
interface Vlan100
 ip address 10.100.0.2 255.255.255.0
 standby ip 10.100.0.1
 standby priority 20
 standby preempt delay minimum 60
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.1 0.0.0.0 area 10
 network 10.0.1.0 0.0.0.3 area 10
 network 10.100.0.0 0.0.0.255 area 10
!

●3750-2
vlan 100
!
spanning-tree vlan 100
!
spanning-tree mode rapid-pvst
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet1/0/1
 no switchport
 ip address 10.0.2.1 255.255.255.252
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100
 switchport mode trunk
!
interface Vlan100
 ip address 10.100.0.3 255.255.255.0
 standby ip 10.100.0.1
 standby priority 10
 standby preempt delay minimum 60
!
router ospf 1
 network 10.0.0.2 0.0.0.0 area 10
 network 10.0.2.0 0.0.0.3 area 10
 network 10.100.0.0 0.0.0.255 area 10
!

●2960G
vlan 100
!
spanning-tree vlan 100
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/14
 switchport access vlan 100
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/22
 description L3SW-3(3750-1)
 switchport trunk allowed vlan 100
 switchport mode trunk
!
interface GigabitEthernet0/23
 description L3SW-4(3750-2)
 switchport trunk allowed vlan 100
 switchport mode trunk
!

●1812J
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
!
interface FastEthernet0
 ip address 10.0.1.2 255.255.255.252
!
interface FastEthernet1
 ip address 10.0.2.2 255.255.255.252
 ip ospf cost 20
!
interface FastEthernet2
 switchport access vlan 200
 spanning-tree portfast
!
!
interface Vlan200
 ip address 10.200.0.1 255.255.255.0
!
router ospf 1
 network 10.0.0.3 0.0.0.0 area 10
 network 10.0.1.0 0.0.0.3 area 10
 network 10.0.2.0 0.0.0.3 area 10
 network 10.200.0.0 0.0.0.255 area 10
!

各ケーブルをつなぐと3750-1でのHSRP状態は以下の通り。

L3SW-3#sh stand br
Load for five secs: 6%/0%; one minute: 4%; five minutes: 2%
No time source, *09:03:46.626 JST Mon Mar 1 1993
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP    
Vl100       0   20   P Active   local           10.100.0.3      10.100.0.1    
L3SW-3#

仮想IPアドレスがあり、3750-2のstandbyも認識しています。
この状態でHSRPの動作実験をします。
PCとIPSTにIPアドレスを振り、Expingでpingを連続実行し、
各ケーブルを抜線していきます。

定常状態ではPC→2960G→3750-1→1812J→IPST
の経路を通ります。

パターンA
3750-1と2960Gの間のケーブルを抜線
断時間は0.3秒
ケーブルを戻した際の復旧切り替え断は無し
この場合は、HSRP動作は変化せずV100の
スパニングツリーが動作しただけ。
PC→2960G→3750-2→3750-1→1812J→IPSTという経路になる

パターンB
3750-1と1812Jの間のケーブルを抜線
断時間は7秒
ケーブルを戻した際、OSPFネイバーが確立するまで50秒かかる
復旧切り替え断は無し
この場合も、HSRP動作は変化せず
OSPFの経路が3750-2→1812Jに変わる
3750-1も生きている為
PC→2960G→3750-1→3750-2→1812J→IPSTという経路になる

パターンC
3750-1の電源を切る
断時間は13秒
再度電源ONして定常動作まではしばらくかかり、
時々通信断が起きる
1812JとのOSPFネイバーが確立後、さらに60秒後にHSRPがActiveになる
この場合は、HSRP動作する
3750-1がダウンしたことで3750-2のHSRPが動作し
standbyからactiveへ遷移する
PCからは同じゲートウェイに見えるので
3750-2を経由して通信が復旧する
PC→2960G→3750-2→1812J→IPSTという経路になる
復旧の際、3750-1にはpreempt delayを指定しているので
OSPFネイバー確立後すぐに切り替わらず、
さらに60秒後にstandbyからactiveに遷移する

パターンD
まず3750-1と1812Jの間のケーブルを抜線
断時間は7秒
次に3750-1と3750-2の間のケーブルを抜線
断時間は0.3秒
最後に3750-1と2960Gの間のケーブルを抜線
断時間は13秒
この場合、HSRP動作するのは最後のケーブルを抜線した時

 メモ
HSRPの優先度は値の大きい方が高い
preemptを指定するのは優先度の高い方

configまとめ
standby ip xxx.xxx.xxx.xxx     インターフェイスに仮想アドレスを指定
standby priority yyy        HSRPの優先度(大きいと高い)
standby preempt delay minimum zzz HSRPの復帰遅延時間(秒)

コマンドまとめ
sh standby brief      HSRPの状態表示
sh standby         HSRPの詳細な状態表示
clear ip ospf process   OSPFプロセスの再起動

参考書籍
CiscoIOSコマンド辞典 

『コンピューター機器』 ジャンルのランキング
コメント   この記事についてブログを書く
この記事をはてなブックマークに追加
« [ucom]お試しPython | トップ | [ucom]SFP光源化 »

コメントを投稿

ブログ作成者から承認されるまでコメントは反映されません。