最適化問題に対する超高速&安定計算

クラスタ計算機やスーパーコンピュータ上での大規模最適化問題やグラフ探索などの研究のお話が中心

Caffe, Boost, CUDA, cuDNN

2017年08月10日 12時58分36秒 | Weblog
Caffe のインストール&実行要件が Boost 1.55 になっています。

Boost >= 1.55

ただし CentOS 7 でインストールされている Boost は 1.53 になっています。
boost-1.53.0-26.el7.x86_64

仕方がないので、Boost 1.64 をダウンロード
https://sourceforge.net/projects/boost/files/boost/

Boost 1.53 にアンインストール
> yum remove boost boost-devel

Boost 1.64 のビルドとインストール
> ./bootstrap.sh
> ./b2 install -j15 --prefix=/usr/local/boost link=static,shared runtime-link=shared threading=multi

環境変数の設定
/etc/bashrc に追加

export LIBRARY_PATH=/usr/local/boost/lib:$LIBRARY_PATH
export LD_LIBRARY_PATH=/usr/local/boost/lib:$LD_LIBRARY_PATH
export CPLUS_INCLUDE_PATH=/usr/local/boost/include:$CPLUS_INCLUDE_PATH

> /sbin/ldconfig

また CUDA と cuDNN は以下をインストールしました。
cuda_8.0.61_375.26_linux.run
cudnn-8.0-linux-x64-v7.tgz




ジャンル:
ウェブログ
コメント   この記事についてブログを書く
この記事をはてなブックマークに追加
« 某所での某スパコン設置作業中 | トップ | SDPARA 7.6.1 その3 »
最近の画像もっと見る

コメントを投稿

ブログ作成者から承認されるまでコメントは反映されません。

コメント利用規約に同意の上コメント投稿を行ってください。

数字4桁を入力し、投稿ボタンを押してください。

あわせて読む

トラックバック

この記事のトラックバック  Ping-URL
ブログ作成者から承認されるまでトラックバックは反映されません。